ipq806x: add 5.4 as testing kernel version
[openwrt/staging/rmilecki.git] / target / linux / ipq806x / Makefile
index 36b32053bd1be2db6775f71728e5a3bb57965c8d..42f91371c37edd13faa278280b2ae25706aa8013 100644 (file)
@@ -5,17 +5,24 @@ include $(TOPDIR)/rules.mk
 ARCH:=arm
 BOARD:=ipq806x
 BOARDNAME:=Qualcomm Atheros IPQ806X
-FEATURES:=squashfs
-CPU_TYPE:=cortex-a7
-MAINTAINER:=John Crispin <blogic@openwrt.org>
+FEATURES:=squashfs nand fpu ramdisk
+CPU_TYPE:=cortex-a15
+CPU_SUBTYPE:=neon-vfpv4
+MAINTAINER:=John Crispin <john@phrozen.org>
+SUBTARGETS:=generic
 
-KERNEL_PATCHVER:=3.18
+KERNEL_PATCHVER:=4.19
+KERNEL_TESTING_PATCHVER:=5.4
 
-KERNELNAME:=Image dtbs
+KERNELNAME:=zImage Image dtbs
 
 include $(INCLUDE_DIR)/target.mk
 DEFAULT_PACKAGES += \
-       kmod-leds-gpio kmod-gpio-button-hotplug kmod-qca-nss-gmac swconfig
-
+       kmod-leds-gpio kmod-gpio-button-hotplug swconfig \
+       kmod-ata-core kmod-ata-ahci kmod-ata-ahci-platform \
+       kmod-usb-ohci kmod-usb2 kmod-usb-ledtrig-usbport \
+       kmod-usb-phy-qcom-dwc3 kmod-usb3 kmod-usb-dwc3-qcom \
+       kmod-ath10k-ct wpad-basic \
+       uboot-envtools
 
 $(eval $(call BuildTarget))