ipq806x: update USB3 modules for 4.19
[openwrt/staging/wigyori.git] / target / linux / ipq806x / Makefile
index 6207c9126fead2d169bd3d459399331b32479086..bb968e75d36a91c8bb4dd7fc84f1c36e8592958f 100644 (file)
@@ -5,14 +5,23 @@ include $(TOPDIR)/rules.mk
 ARCH:=arm
 BOARD:=ipq806x
 BOARDNAME:=Qualcomm Atheros IPQ806X
-FEATURES:=squashfs
-CPU_TYPE:=cortex-a7
-MAINTAINER:=John Crispin <blogic@openwrt.org>
+FEATURES:=squashfs nand fpu ramdisk
+CPU_TYPE:=cortex-a15
+CPU_SUBTYPE:=neon-vfpv4
+MAINTAINER:=John Crispin <john@phrozen.org>
+SUBTARGETS:=generic
 
-LINUX_VERSION:=3.14.18
+KERNEL_PATCHVER:=4.14
 
-KERNELNAME="Image dtbs"
+KERNELNAME:=zImage Image dtbs
 
 include $(INCLUDE_DIR)/target.mk
+DEFAULT_PACKAGES += \
+       kmod-leds-gpio kmod-gpio-button-hotplug swconfig \
+       kmod-ata-core kmod-ata-ahci kmod-ata-ahci-platform \
+       kmod-usb-ohci kmod-usb2 kmod-usb-ledtrig-usbport \
+       kmod-usb-phy-qcom-dwc3 kmod-usb3 kmod-usb-dwc3-qcom \
+       kmod-ath10k-ct wpad-basic \
+       uboot-envtools
 
 $(eval $(call BuildTarget))