realtek: Fix VLAN issues introduced by multicast patches
[openwrt/staging/dedeckeh.git] / target / linux / ipq806x / modules.mk
index 43f3c9cfe72c388974c3a08fef3d65a7b1840d97..605504b0c33867bd0ad944212c3097d74aeafc20 100644 (file)
@@ -1,33 +1,16 @@
-define KernelPackage/usb-dwc3-of-simple
-  TITLE:=DWC3 USB simple OF driver
-  DEPENDS:=+kmod-usb-dwc3
-  KCONFIG:= CONFIG_USB_DWC3_OF_SIMPLE
-  FILES:= $(LINUX_DIR)/drivers/usb/dwc3/dwc3-of-simple.ko
-  AUTOLOAD:=$(call AutoLoad,53,dwc3-of-simple,1)
-  $(call AddDepends/usb)
-endef
-
-define KernelPackage/usb-dwc3-of-simple/description
- This driver provides generic platform glue for the integrated DesignWare
- USB3 IP Core.
-endef
-
-$(eval $(call KernelPackage,usb-dwc3-of-simple))
-
-define KernelPackage/usb-phy-qcom-dwc3
-  TITLE:=DWC3 USB QCOM PHY driver
-  DEPENDS:=@TARGET_ipq806x +kmod-usb-dwc3-of-simple
-  KCONFIG:= CONFIG_PHY_QCOM_DWC3
+define KernelPackage/phy-qcom-ipq806x-usb
+  TITLE:=Qualcomm IPQ806x DWC3 USB PHY driver
+  DEPENDS:=@TARGET_ipq806x
+  KCONFIG:= CONFIG_PHY_QCOM_IPQ806X_USB
   FILES:= \
-    $(LINUX_DIR)/drivers/phy/phy-qcom-dwc3.ko@lt4.13 \
-    $(LINUX_DIR)/drivers/phy/qualcomm/phy-qcom-dwc3.ko@ge4.13
-  AUTOLOAD:=$(call AutoLoad,45,phy-qcom-dwc3,1)
+    $(LINUX_DIR)/drivers/phy/qualcomm/phy-qcom-ipq806x-usb.ko
+  AUTOLOAD:=$(call AutoLoad,45,phy-qcom-ipq806x-usb,1)
   $(call AddDepends/usb)
 endef
 
-define KernelPackage/usb-phy-qcom-dwc3/description
+define KernelPackage/phy-qcom-ipq806x-usb/description
  This driver provides support for the integrated DesignWare
  USB3 IP Core within the QCOM SoCs.
 endef
 
-$(eval $(call KernelPackage,usb-phy-qcom-dwc3))
+$(eval $(call KernelPackage,phy-qcom-ipq806x-usb))