ath79: fix node names
[openwrt/staging/wigyori.git] / target / linux / ixp4xx / Makefile
index ec931a0a991a02833262b34534ff75776943ea95..e1964331a0f5220e68175d99bce2e9ee64aa3b51 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2008 OpenWrt.org
+# Copyright (C) 2006-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,14 +8,17 @@ include $(TOPDIR)/rules.mk
 
 ARCH:=armeb
 BOARD:=ixp4xx
-BOARDNAME:=Intel XScale IXP4xx
+BOARDNAME:=Intel IXP4xx
 FEATURES:=squashfs
-SUBTARGETS=generic harddisk
+MAINTAINER:=Ted Hess <thess@kitschensync.net>, \
+           Imre Kaloz <kaloz@openwrt.org>
+SUBTARGETS:=generic harddisk
 
-LINUX_VERSION:=2.6.23.16
+KERNEL_PATCHVER:=4.9
 
 include $(INCLUDE_DIR)/target.mk
 
-DEFAULT_PACKAGES += ixp4xx-microcode
+DEFAULT_PACKAGES += ixp4xx-microcode fconfig
+KERNELNAME:=zImage
 
 $(eval $(call BuildTarget))