refresh ixp4xx patches to match upstream style
[openwrt/svn-archive/archive.git] / target / linux / ixp4xx / patches-2.6.25 / 030-ixp4xx_fsg_board_support.patch
index de874e44ad53a1ed7fd890c8e451c621ecf25c0b..8fb7280e079bca32e8d88967840d37f727414556 100644 (file)
@@ -45,11 +45,9 @@ now calls machine_restart() directly.
  create mode 100644 arch/arm/mach-ixp4xx/fsg-setup.c
  create mode 100644 include/asm-arm/arch-ixp4xx/fsg.h
 
-diff --git a/arch/arm/configs/ixp4xx_defconfig b/arch/arm/configs/ixp4xx_defconfig
-index efa0485..fc14932 100644
 --- a/arch/arm/configs/ixp4xx_defconfig
 +++ b/arch/arm/configs/ixp4xx_defconfig
-@@ -165,6 +165,7 @@ CONFIG_ARCH_PRPMC1100=y
+@@ -165,6 +165,7 @@
  CONFIG_MACH_NAS100D=y
  CONFIG_MACH_DSMG600=y
  CONFIG_ARCH_IXDP4XX=y
@@ -57,7 +55,7 @@ index efa0485..fc14932 100644
  CONFIG_CPU_IXP46X=y
  CONFIG_CPU_IXP43X=y
  CONFIG_MACH_GTWX5715=y
-@@ -770,7 +771,7 @@ CONFIG_ATA=y
+@@ -770,7 +771,7 @@
  # CONFIG_SATA_SIL24 is not set
  # CONFIG_SATA_SIS is not set
  # CONFIG_SATA_ULI is not set
@@ -66,7 +64,7 @@ index efa0485..fc14932 100644
  # CONFIG_SATA_VITESSE is not set
  # CONFIG_SATA_INIC162X is not set
  # CONFIG_PATA_ALI is not set
-@@ -1143,7 +1144,7 @@ CONFIG_HWMON=y
+@@ -1143,7 +1144,7 @@
  # CONFIG_SENSORS_VIA686A is not set
  # CONFIG_SENSORS_VT1211 is not set
  # CONFIG_SENSORS_VT8231 is not set
@@ -75,7 +73,7 @@ index efa0485..fc14932 100644
  # CONFIG_SENSORS_W83791D is not set
  # CONFIG_SENSORS_W83792D is not set
  # CONFIG_SENSORS_W83793 is not set
-@@ -1334,8 +1335,8 @@ CONFIG_LEDS_CLASS=y
+@@ -1334,8 +1335,8 @@
  #
  # LED drivers
  #
@@ -85,7 +83,7 @@ index efa0485..fc14932 100644
  
  #
  # LED Triggers
-@@ -1367,7 +1368,7 @@ CONFIG_RTC_INTF_DEV=y
+@@ -1367,7 +1368,7 @@
  # CONFIG_RTC_DRV_DS1672 is not set
  # CONFIG_RTC_DRV_MAX6900 is not set
  # CONFIG_RTC_DRV_RS5C372 is not set
@@ -94,11 +92,9 @@ index efa0485..fc14932 100644
  CONFIG_RTC_DRV_X1205=y
  CONFIG_RTC_DRV_PCF8563=y
  # CONFIG_RTC_DRV_PCF8583 is not set
-diff --git a/arch/arm/mach-ixp4xx/Kconfig b/arch/arm/mach-ixp4xx/Kconfig
-index e774447..db8b5fe 100644
 --- a/arch/arm/mach-ixp4xx/Kconfig
 +++ b/arch/arm/mach-ixp4xx/Kconfig
-@@ -125,6 +125,15 @@ config    ARCH_IXDP4XX
+@@ -125,6 +125,15 @@
        depends on ARCH_IXDP425 || MACH_IXDP465 || MACH_KIXRP435
        default y
  
@@ -114,11 +110,9 @@ index e774447..db8b5fe 100644
  #
  # Certain registers and IRQs are only enabled if supporting IXP465 CPUs
  #
-diff --git a/arch/arm/mach-ixp4xx/Makefile b/arch/arm/mach-ixp4xx/Makefile
-index c195688..2e6bbf9 100644
 --- a/arch/arm/mach-ixp4xx/Makefile
 +++ b/arch/arm/mach-ixp4xx/Makefile
-@@ -15,6 +15,7 @@ obj-pci-$(CONFIG_MACH_NAS100D)               += nas100d-pci.o
+@@ -15,6 +15,7 @@
  obj-pci-$(CONFIG_MACH_DSMG600)                += dsmg600-pci.o
  obj-pci-$(CONFIG_MACH_GATEWAY7001)    += gateway7001-pci.o
  obj-pci-$(CONFIG_MACH_WG302V2)                += wg302v2-pci.o
@@ -126,7 +120,7 @@ index c195688..2e6bbf9 100644
  
  obj-y += common.o
  
-@@ -28,6 +29,7 @@ obj-$(CONFIG_MACH_NAS100D)   += nas100d-setup.o
+@@ -28,6 +29,7 @@
  obj-$(CONFIG_MACH_DSMG600)      += dsmg600-setup.o
  obj-$(CONFIG_MACH_GATEWAY7001)        += gateway7001-setup.o
  obj-$(CONFIG_MACH_WG302V2)    += wg302v2-setup.o
@@ -134,9 +128,6 @@ index c195688..2e6bbf9 100644
  
  obj-$(CONFIG_PCI)             += $(obj-pci-$(CONFIG_PCI)) common-pci.o
  obj-$(CONFIG_IXP4XX_QMGR)     += ixp4xx_qmgr.o
-diff --git a/arch/arm/mach-ixp4xx/fsg-pci.c b/arch/arm/mach-ixp4xx/fsg-pci.c
-new file mode 100644
-index 0000000..f19f3f6
 --- /dev/null
 +++ b/arch/arm/mach-ixp4xx/fsg-pci.c
 @@ -0,0 +1,71 @@
@@ -211,9 +202,6 @@ index 0000000..f19f3f6
 +}
 +
 +subsys_initcall(fsg_pci_init);
-diff --git a/arch/arm/mach-ixp4xx/fsg-setup.c b/arch/arm/mach-ixp4xx/fsg-setup.c
-new file mode 100644
-index 0000000..0db3a90
 --- /dev/null
 +++ b/arch/arm/mach-ixp4xx/fsg-setup.c
 @@ -0,0 +1,276 @@
@@ -493,9 +481,6 @@ index 0000000..0db3a90
 +      .init_machine   = fsg_init,
 +MACHINE_END
 +
-diff --git a/include/asm-arm/arch-ixp4xx/fsg.h b/include/asm-arm/arch-ixp4xx/fsg.h
-new file mode 100644
-index 0000000..c0100cc
 --- /dev/null
 +++ b/include/asm-arm/arch-ixp4xx/fsg.h
 @@ -0,0 +1,50 @@
@@ -549,8 +534,6 @@ index 0000000..c0100cc
 +#define FSG_LED_USB_BIT               4
 +#define FSG_LED_RING_BIT      5
 +#define FSG_LED_SYNC_BIT      7
-diff --git a/include/asm-arm/arch-ixp4xx/hardware.h b/include/asm-arm/arch-ixp4xx/hardware.h
-index 73e8dc3..fa723a6 100644
 --- a/include/asm-arm/arch-ixp4xx/hardware.h
 +++ b/include/asm-arm/arch-ixp4xx/hardware.h
 @@ -45,5 +45,6 @@
@@ -560,8 +543,6 @@ index 73e8dc3..fa723a6 100644
 +#include "fsg.h"
  
  #endif  /* _ASM_ARCH_HARDWARE_H */
-diff --git a/include/asm-arm/arch-ixp4xx/irqs.h b/include/asm-arm/arch-ixp4xx/irqs.h
-index 1180160..674af4a 100644
 --- a/include/asm-arm/arch-ixp4xx/irqs.h
 +++ b/include/asm-arm/arch-ixp4xx/irqs.h
 @@ -128,4 +128,11 @@
@@ -576,6 +557,3 @@ index 1180160..674af4a 100644
 +#define        IRQ_FSG_PCI_INTC        IRQ_IXP4XX_GPIO5
 +
  #endif
--- 
-1.5.2.5
-