refresh ixp4xx patches to match upstream style
[openwrt/staging/florian.git] / target / linux / ixp4xx / patches-2.6.25 / 160-wg302v1_support.patch
index b0b43348df8eabf3d5d9dd4f40b5131abd0135de..a5a6e5ca965e3a06f8296d26a281762dbd7f042e 100644 (file)
@@ -1,8 +1,6 @@
-Index: linux-2.6.25.4/arch/arm/mach-ixp4xx/Kconfig
-===================================================================
---- linux-2.6.25.4.orig/arch/arm/mach-ixp4xx/Kconfig
-+++ linux-2.6.25.4/arch/arm/mach-ixp4xx/Kconfig
-@@ -49,6 +49,14 @@ config MACH_GATEWAY7001
+--- a/arch/arm/mach-ixp4xx/Kconfig
++++ b/arch/arm/mach-ixp4xx/Kconfig
+@@ -49,6 +49,14 @@
          7001 Access Point. For more information on this platform,
          see http://openwrt.org
  
@@ -17,11 +15,9 @@ Index: linux-2.6.25.4/arch/arm/mach-ixp4xx/Kconfig
  config MACH_WG302V2
        bool "Netgear WG302 v2 / WAG302 v2"
        select PCI
-Index: linux-2.6.25.4/arch/arm/mach-ixp4xx/Makefile
-===================================================================
---- linux-2.6.25.4.orig/arch/arm/mach-ixp4xx/Makefile
-+++ linux-2.6.25.4/arch/arm/mach-ixp4xx/Makefile
-@@ -14,6 +14,7 @@ obj-pci-$(CONFIG_MACH_NSLU2)         += nslu2-p
+--- a/arch/arm/mach-ixp4xx/Makefile
++++ b/arch/arm/mach-ixp4xx/Makefile
+@@ -14,6 +14,7 @@
  obj-pci-$(CONFIG_MACH_NAS100D)                += nas100d-pci.o
  obj-pci-$(CONFIG_MACH_DSMG600)                += dsmg600-pci.o
  obj-pci-$(CONFIG_MACH_GATEWAY7001)    += gateway7001-pci.o
@@ -29,7 +25,7 @@ Index: linux-2.6.25.4/arch/arm/mach-ixp4xx/Makefile
  obj-pci-$(CONFIG_MACH_WG302V2)                += wg302v2-pci.o
  obj-pci-$(CONFIG_MACH_FSG)            += fsg-pci.o
  obj-pci-$(CONFIG_MACH_PRONGHORNMETRO) += pronghornmetro-pci.o
-@@ -33,6 +34,7 @@ obj-$(CONFIG_MACH_NSLU2)     += nslu2-setup.
+@@ -33,6 +34,7 @@
  obj-$(CONFIG_MACH_NAS100D)    += nas100d-setup.o
  obj-$(CONFIG_MACH_DSMG600)      += dsmg600-setup.o
  obj-$(CONFIG_MACH_GATEWAY7001)        += gateway7001-setup.o
@@ -37,10 +33,8 @@ Index: linux-2.6.25.4/arch/arm/mach-ixp4xx/Makefile
  obj-$(CONFIG_MACH_WG302V2)    += wg302v2-setup.o
  obj-$(CONFIG_MACH_FSG)                += fsg-setup.o
  obj-$(CONFIG_MACH_PRONGHORNMETRO)     += pronghornmetro-setup.o
-Index: linux-2.6.25.4/arch/arm/mach-ixp4xx/wg302v1-pci.c
-===================================================================
 --- /dev/null
-+++ linux-2.6.25.4/arch/arm/mach-ixp4xx/wg302v1-pci.c
++++ b/arch/arm/mach-ixp4xx/wg302v1-pci.c
 @@ -0,0 +1,63 @@
 +/*
 + * arch/arch/mach-ixp4xx/wg302v1-pci.c
@@ -105,10 +99,8 @@ Index: linux-2.6.25.4/arch/arm/mach-ixp4xx/wg302v1-pci.c
 +}
 +
 +subsys_initcall(wg302v1_pci_init);
-Index: linux-2.6.25.4/arch/arm/mach-ixp4xx/wg302v1-setup.c
-===================================================================
 --- /dev/null
-+++ linux-2.6.25.4/arch/arm/mach-ixp4xx/wg302v1-setup.c
++++ b/arch/arm/mach-ixp4xx/wg302v1-setup.c
 @@ -0,0 +1,109 @@
 +/*
 + * arch/arm/mach-ixp4xx/wg302v1-setup.c