refresh ixp4xx patches to match upstream style
[openwrt/staging/florian.git] / target / linux / ixp4xx / patches-2.6.25 / 180-tw5334_support.patch
index e4a8bf5eee8732d7c8afc4128aa8f4d6ea5b41c6..c403a87fc987a0806e011695a01c15ad7ec63821 100644 (file)
@@ -1,8 +1,6 @@
-Index: linux-2.6.25.4/arch/arm/mach-ixp4xx/Kconfig
-===================================================================
---- linux-2.6.25.4.orig/arch/arm/mach-ixp4xx/Kconfig
-+++ linux-2.6.25.4/arch/arm/mach-ixp4xx/Kconfig
-@@ -150,6 +150,14 @@ config ARCH_PRPMC1100
+--- a/arch/arm/mach-ixp4xx/Kconfig
++++ b/arch/arm/mach-ixp4xx/Kconfig
+@@ -150,6 +150,14 @@
          PrPCM1100 Processor Mezanine Module. For more information on
          this platform, see <file:Documentation/arm/IXP4xx>.
  
@@ -17,11 +15,9 @@ Index: linux-2.6.25.4/arch/arm/mach-ixp4xx/Kconfig
  config MACH_NAS100D
        bool
        prompt "NAS100D"
-Index: linux-2.6.25.4/arch/arm/mach-ixp4xx/Makefile
-===================================================================
---- linux-2.6.25.4.orig/arch/arm/mach-ixp4xx/Makefile
-+++ linux-2.6.25.4/arch/arm/mach-ixp4xx/Makefile
-@@ -22,6 +22,7 @@ obj-pci-$(CONFIG_MACH_COMPEX)                += ixdp42
+--- a/arch/arm/mach-ixp4xx/Makefile
++++ b/arch/arm/mach-ixp4xx/Makefile
+@@ -22,6 +22,7 @@
  obj-pci-$(CONFIG_MACH_WRT300NV2)              += wrt300nv2-pci.o
  obj-pci-$(CONFIG_MACH_SIDEWINDER)             += sidewinder-pci.o
  obj-pci-$(CONFIG_MACH_AP1000)         += ixdp425-pci.o
@@ -29,7 +25,7 @@ Index: linux-2.6.25.4/arch/arm/mach-ixp4xx/Makefile
  
  obj-y += common.o
  
-@@ -42,6 +43,7 @@ obj-$(CONFIG_MACH_COMPEX)    += compex-setu
+@@ -42,6 +43,7 @@
  obj-$(CONFIG_MACH_WRT300NV2)  += wrt300nv2-setup.o
  obj-$(CONFIG_MACH_SIDEWINDER) += sidewinder-setup.o
  obj-$(CONFIG_MACH_AP1000)     += ap1000-setup.o
@@ -37,10 +33,8 @@ Index: linux-2.6.25.4/arch/arm/mach-ixp4xx/Makefile
  
  obj-$(CONFIG_PCI)             += $(obj-pci-$(CONFIG_PCI)) common-pci.o
  obj-$(CONFIG_IXP4XX_QMGR)     += ixp4xx_qmgr.o
-Index: linux-2.6.25.4/arch/arm/mach-ixp4xx/tw5334-setup.c
-===================================================================
 --- /dev/null
-+++ linux-2.6.25.4/arch/arm/mach-ixp4xx/tw5334-setup.c
++++ b/arch/arm/mach-ixp4xx/tw5334-setup.c
 @@ -0,0 +1,162 @@
 +/*
 + * arch/arm/mach-ixp4xx/tw5334-setup.c
@@ -204,10 +198,8 @@ Index: linux-2.6.25.4/arch/arm/mach-ixp4xx/tw5334-setup.c
 +      .init_machine   = tw5334_init,
 +MACHINE_END
 +#endif
-Index: linux-2.6.25.4/arch/arm/mach-ixp4xx/tw5334-pci.c
-===================================================================
 --- /dev/null
-+++ linux-2.6.25.4/arch/arm/mach-ixp4xx/tw5334-pci.c
++++ b/arch/arm/mach-ixp4xx/tw5334-pci.c
 @@ -0,0 +1,69 @@
 +/*
 + * arch/arch/mach-ixp4xx/tw5334-pci.c
@@ -278,11 +270,9 @@ Index: linux-2.6.25.4/arch/arm/mach-ixp4xx/tw5334-pci.c
 +}
 +
 +subsys_initcall(tw5334_pci_init);
-Index: linux-2.6.25.4/include/asm-arm/arch-ixp4xx/uncompress.h
-===================================================================
---- linux-2.6.25.4.orig/include/asm-arm/arch-ixp4xx/uncompress.h
-+++ linux-2.6.25.4/include/asm-arm/arch-ixp4xx/uncompress.h
-@@ -42,7 +42,8 @@ static __inline__ void __arch_decomp_set
+--- a/include/asm-arm/arch-ixp4xx/uncompress.h
++++ b/include/asm-arm/arch-ixp4xx/uncompress.h
+@@ -42,7 +42,8 @@
         */
        if (machine_is_adi_coyote() || machine_is_gtwx5715() ||
                         machine_is_gateway7001() || machine_is_wg302v2() ||