refresh ixp4xx patches to match upstream style
[openwrt/staging/wigyori.git] / target / linux / ixp4xx / patches-2.6.25 / 200-npe_driver.patch
index 9b34b8a2b18f00226f969a66404e84ab57ed7175..394c3a18992b9ad71d7461b8e7bc7265865dc22f 100644 (file)
@@ -1,8 +1,6 @@
-Index: linux-2.6.25.4/drivers/net/arm/Kconfig
-===================================================================
---- linux-2.6.25.4.orig/drivers/net/arm/Kconfig
-+++ linux-2.6.25.4/drivers/net/arm/Kconfig
-@@ -47,3 +47,11 @@ config EP93XX_ETH
+--- a/drivers/net/arm/Kconfig
++++ b/drivers/net/arm/Kconfig
+@@ -47,3 +47,11 @@
        help
          This is a driver for the ethernet hardware included in EP93xx CPUs.
          Say Y if you are building a kernel for EP93xx based devices.
@@ -14,19 +12,15 @@ Index: linux-2.6.25.4/drivers/net/arm/Kconfig
 +      help
 +        Say Y here if you want to use built-in Ethernet ports
 +        on IXP4xx processor.
-Index: linux-2.6.25.4/drivers/net/arm/Makefile
-===================================================================
---- linux-2.6.25.4.orig/drivers/net/arm/Makefile
-+++ linux-2.6.25.4/drivers/net/arm/Makefile
-@@ -9,3 +9,4 @@ obj-$(CONFIG_ARM_ETHER3)       += ether3.o
+--- a/drivers/net/arm/Makefile
++++ b/drivers/net/arm/Makefile
+@@ -9,3 +9,4 @@
  obj-$(CONFIG_ARM_ETHER1)      += ether1.o
  obj-$(CONFIG_ARM_AT91_ETHER)  += at91_ether.o
  obj-$(CONFIG_EP93XX_ETH)      += ep93xx_eth.o
 +obj-$(CONFIG_IXP4XX_ETH)      += ixp4xx_eth.o
-Index: linux-2.6.25.4/drivers/net/arm/ixp4xx_eth.c
-===================================================================
 --- /dev/null
-+++ linux-2.6.25.4/drivers/net/arm/ixp4xx_eth.c
++++ b/drivers/net/arm/ixp4xx_eth.c
 @@ -0,0 +1,1265 @@
 +/*
 + * Intel IXP4xx Ethernet driver for Linux
@@ -1293,11 +1287,9 @@ Index: linux-2.6.25.4/drivers/net/arm/ixp4xx_eth.c
 +MODULE_ALIAS("platform:ixp4xx_eth");
 +module_init(eth_init_module);
 +module_exit(eth_cleanup_module);
-Index: linux-2.6.25.4/arch/arm/mach-ixp4xx/ixp4xx_npe.c
-===================================================================
---- linux-2.6.25.4.orig/arch/arm/mach-ixp4xx/ixp4xx_npe.c
-+++ linux-2.6.25.4/arch/arm/mach-ixp4xx/ixp4xx_npe.c
-@@ -448,7 +448,9 @@ int npe_send_message(struct npe *npe, co
+--- a/arch/arm/mach-ixp4xx/ixp4xx_npe.c
++++ b/arch/arm/mach-ixp4xx/ixp4xx_npe.c
+@@ -448,7 +448,9 @@
                return -ETIMEDOUT;
        }
  
@@ -1307,7 +1299,7 @@ Index: linux-2.6.25.4/arch/arm/mach-ixp4xx/ixp4xx_npe.c
        return 0;
  }
  
-@@ -484,7 +486,9 @@ int npe_recv_message(struct npe *npe, vo
+@@ -484,7 +486,9 @@
                return -ETIMEDOUT;
        }
  
@@ -1317,11 +1309,9 @@ Index: linux-2.6.25.4/arch/arm/mach-ixp4xx/ixp4xx_npe.c
        return 0;
  }
  
-Index: linux-2.6.25.4/arch/arm/mach-ixp4xx/ixp4xx_qmgr.c
-===================================================================
---- linux-2.6.25.4.orig/arch/arm/mach-ixp4xx/ixp4xx_qmgr.c
-+++ linux-2.6.25.4/arch/arm/mach-ixp4xx/ixp4xx_qmgr.c
-@@ -184,6 +184,8 @@ void qmgr_release_queue(unsigned int que
+--- a/arch/arm/mach-ixp4xx/ixp4xx_qmgr.c
++++ b/arch/arm/mach-ixp4xx/ixp4xx_qmgr.c
+@@ -184,6 +184,8 @@
        case 3: mask[0] = 0xFF; break;
        }