fix the IXP4xx CF driver patch for 2.6.30
[openwrt/svn-archive/archive.git] / target / linux / ixp4xx / patches-2.6.30 / 295-latch_led_driver.patch
index b980570d36ef9b5bb03323cfea1185d79ae3b7b1..9cbf5e971938949e4062b42ca99e5abddb1d3d47 100644 (file)
@@ -1,8 +1,8 @@
 --- a/drivers/leds/Kconfig
 +++ b/drivers/leds/Kconfig
-@@ -119,6 +119,13 @@ config LEDS_GPIO
-         outputs. To be useful the particular board must have LEDs
-         and they must be connected to the GPIO lines.
+@@ -155,6 +155,13 @@ config LEDS_LP5521
+         This driver can be built as a module by choosing 'M'. The module
+         will be called leds-lp5521.
  
 +config LEDS_LATCH
 +      tristate "LED Support for Memory Latched LEDs"
@@ -12,8 +12,8 @@
 +
 +
  config LEDS_CLEVO_MAIL
-       tristate "Mail LED on Clevo notebook (EXPERIMENTAL)"
-       depends on LEDS_CLASS && X86 && SERIO_I8042 && DMI && EXPERIMENTAL
+       tristate "Mail LED on Clevo notebook"
+       depends on LEDS_CLASS && X86 && SERIO_I8042 && DMI
 --- /dev/null
 +++ b/drivers/leds/leds-latch.c
 @@ -0,0 +1,149 @@
 +MODULE_LICENSE("GPL");
 --- a/drivers/leds/Makefile
 +++ b/drivers/leds/Makefile
-@@ -18,6 +18,7 @@ obj-$(CONFIG_LEDS_COBALT_RAQ)                += leds-c
+@@ -20,6 +20,7 @@ obj-$(CONFIG_LEDS_COBALT_RAQ)                += leds-c
  obj-$(CONFIG_LEDS_SUNFIRE)            += leds-sunfire.o
  obj-$(CONFIG_LEDS_PCA9532)            += leds-pca9532.o
  obj-$(CONFIG_LEDS_GPIO)                       += leds-gpio.o
  obj-$(CONFIG_LEDS_FSG)                        += leds-fsg.o
 --- a/include/linux/leds.h
 +++ b/include/linux/leds.h
-@@ -151,5 +151,19 @@ struct gpio_led_platform_data {
+@@ -153,5 +153,19 @@ struct gpio_led_platform_data {
                                        unsigned long *delay_off);
  };