enable start-stop-daemon by default, i want to use this to clean up a few init script...
[openwrt/staging/dedeckeh.git] / target / linux / ixp4xx-2.6 / Makefile
index 86df91fd8280c2f5f9a8afe6f04fc36f32b470ef..25b60a47b720fe3c96c4b7be6d6802b9d885ea27 100644 (file)
@@ -6,18 +6,19 @@
 #
 include $(TOPDIR)/rules.mk
 
-ARCH:=arm
+ARCH:=armeb
 BOARD:=ixp4xx
 BOARDNAME:=Intel XScale IXP4xx
-FEATURES:=pci usb jffs2
+FEATURES:=squashfs
+
+LINUX_VERSION:=2.6.21.6
 
 define Target/Description
 endef
 
+include $(INCLUDE_DIR)/kernel-build.mk
 
-LINUX_VERSION:=2.6.17
-LINUX_RELEASE:=1
-LINUX_KERNEL_MD5SUM:=37ddefe96625502161f075b9d907f21e
+# include the profiles
+-include profiles/*.mk
 
-include $(INCLUDE_DIR)/kernel-build.mk
 $(eval $(call BuildKernel))