kirkwood: add generic subtarget
[openwrt/staging/dedeckeh.git] / target / linux / kirkwood / Makefile
index 4d92a0613000b0a5195bdc45195d20f9513b9d98..4827d90ee2dee0aafea2703e402761bb5328a408 100644 (file)
@@ -1,22 +1,23 @@
+# SPDX-License-Identifier: GPL-2.0-only
 #
-# Copyright (C) 2009-2013 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
+# Copyright (C) 2009-2015 OpenWrt.org
+
 include $(TOPDIR)/rules.mk
 
 ARCH:=arm
 BOARD:=kirkwood
 BOARDNAME:=Marvell Kirkwood
-FEATURES:=targz usb jffs2_nand ubifs
+FEATURES:=usb nand squashfs ramdisk
 CPU_TYPE:=xscale
-MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
+SUBTARGETS:=generic
 
-LINUX_VERSION:=3.10.28
+KERNEL_PATCHVER:=5.10
+KERNEL_TESTING_PATCHVER:=5.15
 
 include $(INCLUDE_DIR)/target.mk
 
-KERNELNAME:="zImage dtbs"
+KERNELNAME:=zImage dtbs
+
+DEFAULT_PACKAGES += uboot-envtools kmod-usb2
 
 $(eval $(call BuildTarget))