kirkwood: add generic subtarget
[openwrt/staging/dedeckeh.git] / target / linux / kirkwood / Makefile
index b14fb0eab0bd40d5a03ba5ced7617e86dccfb718..4827d90ee2dee0aafea2703e402761bb5328a408 100644 (file)
@@ -1,22 +1,23 @@
+# SPDX-License-Identifier: GPL-2.0-only
 #
-# Copyright (C) 2009 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
+# Copyright (C) 2009-2015 OpenWrt.org
+
 include $(TOPDIR)/rules.mk
 
 ARCH:=arm
 BOARD:=kirkwood
 BOARDNAME:=Marvell Kirkwood
-FEATURES:=jffs2 usb broken
+FEATURES:=usb nand squashfs ramdisk
+CPU_TYPE:=xscale
+SUBTARGETS:=generic
 
-LINUX_VERSION:=2.6.30-rc7
+KERNEL_PATCHVER:=5.10
+KERNEL_TESTING_PATCHVER:=5.15
 
 include $(INCLUDE_DIR)/target.mk
 
-KERNELNAME:="uImage"
+KERNELNAME:=zImage dtbs
 
-DEFAULT_PACKAGES +=
+DEFAULT_PACKAGES += uboot-envtools kmod-usb2
 
 $(eval $(call BuildTarget))