kirkwood: fix initramfs images
[openwrt/staging/lynxis/omap.git] / target / linux / kirkwood / image / Makefile
index 1dfe45f494476b00fa183f3f918c2f6b1076f9b8..dbf8877652734f2b8b9b31e7f2cd5504e81bb7c0 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2009-2010 OpenWrt.org
+# Copyright (C) 2009-2013 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -10,8 +10,10 @@ include $(INCLUDE_DIR)/image.mk
 NAND_BLOCKSIZE := 2048:128k
 
 define Image/BuildKernel
-# do mach-id fixup here, if needed
        cp $(KDIR)/uImage $(BIN_DIR)/$(IMG_PREFIX)-uImage
+ifneq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),)
+       $(CP) $(KDIR)/uImage-initramfs $(BIN_DIR)/$(IMG_PREFIX)-uImage-initramfs
+endif
 endef
 
 define Image/Build