ar71xx: add profile and build image for the TEW-732BR board
[openwrt/svn-archive/archive.git] / target / linux / lantiq / Makefile
index 82e5c3926a51e0eb09d220f0d6e5f04dcf8f3937..ccb30a1a8753dd08cafe64b623bb31920607832c 100644 (file)
@@ -6,15 +6,14 @@
 #
 include $(TOPDIR)/rules.mk
 
-ARCH:=mips
 BOARD:=lantiq
-BOARDNAME:=Lantiq GPON/XWAY
-FEATURES:=squashfs jffs2
-DEFAULT_SUBTARGET:=danube
+BOARDNAME:=Lantiq GPON/XWAY/SVIP
+FEATURES:=squashfs
+SUBTARGETS=xway xrx200 ase falcon
 
-LINUX_VERSION:=2.6.39.2
+LINUX_VERSION:=3.10.12
 
-CFLAGS=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves
+CFLAGS=-Os -pipe -mips32r2 -mno-branch-likely
 
 define Target/Description
        Build firmware images for Lantiq SoC