kernel: refresh patches
[openwrt/svn-archive/archive.git] / target / linux / lantiq / patches-3.14 / 0033-SPI-MIPS-lantiq-adds-spi-xway.patch
index 3a57416841b07d3d0cd111c180d60a46de474d20..fd17b2c0f19ad2faa508ed0c75430d6014255118 100644 (file)
@@ -16,11 +16,9 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
  3 files changed, 986 insertions(+)
  create mode 100644 drivers/spi/spi-xway.c
 
-diff --git a/drivers/spi/Kconfig b/drivers/spi/Kconfig
-index 581ee2a..b2cd93c 100644
 --- a/drivers/spi/Kconfig
 +++ b/drivers/spi/Kconfig
-@@ -527,6 +527,14 @@ config SPI_NUC900
+@@ -536,6 +536,14 @@ config SPI_NUC900
        help
          SPI driver for Nuvoton NUC900 series ARM SoCs
  
@@ -35,18 +33,13 @@ index 581ee2a..b2cd93c 100644
  #
  # Add new SPI master controllers in alphabetical order above this line
  #
-diff --git a/drivers/spi/Makefile b/drivers/spi/Makefile
-index 95af48d..82d3799 100644
 --- a/drivers/spi/Makefile
 +++ b/drivers/spi/Makefile
-@@ -79,3 +79,4 @@ obj-$(CONFIG_SPI_TOPCLIFF_PCH)               += spi-topcliff-pch.o
+@@ -80,3 +80,4 @@ obj-$(CONFIG_SPI_TOPCLIFF_PCH)               += spi-t
  obj-$(CONFIG_SPI_TXX9)                        += spi-txx9.o
  obj-$(CONFIG_SPI_XCOMM)               += spi-xcomm.o
  obj-$(CONFIG_SPI_XILINX)              += spi-xilinx.o
 +obj-$(CONFIG_SPI_XWAY)                        += spi-xway.o
-diff --git a/drivers/spi/spi-xway.c b/drivers/spi/spi-xway.c
-new file mode 100644
-index 0000000..61532e3
 --- /dev/null
 +++ b/drivers/spi/spi-xway.c
 @@ -0,0 +1,977 @@
@@ -1027,6 +1020,3 @@ index 0000000..61532e3
 +MODULE_AUTHOR("Daniel Schwierzeck <daniel.schwierzeck@googlemail.com>");
 +MODULE_LICENSE("GPL");
 +MODULE_ALIAS("platform:spi-xway");
--- 
-1.7.10.4
-