[lantiq] add VG3503J support
[openwrt/svn-archive/archive.git] / target / linux / lantiq / xway / profiles / lantiq.mk
index 2c24d3c95ed8bff363930c513fdbd09f59fbdac2..b4990b660472b0f51e721e26bd5c084c940196da 100644 (file)
@@ -1,19 +1,27 @@
-define Profile/EASY80920-NOR
-  NAME:=EASY80920-NOR
+define Profile/EASY50712
+  NAME:=Lantiq Danube - EASY50712
 endef
 
-define Profile/EASY80920-NOR/Description
-       Lantiq EASY80920 evalkit (NOR)
-endef
-
-$(eval $(call Profile,EASY80920-NOR))
+$(eval $(call Profile,EASY50712))
 
-define Profile/EASY80920-NAND
-  NAME:=EASY80920-NAND
+define Profile/EASY80920NOR
+  NAME:=Lantiq VR9 - EASY80920NOR
+  PACKAGES:=kmod-ath9k wpad-mini \
+       kmod-ltq-deu-vr9 kmod-ltq-hcd-vr9 \
+       kmod-ltq-vdsl-vr9-mei kmod-ltq-vdsl-vr9 \
+       kmod-ltq-atm-vr9 ltq-vdsl-vr9-fw-installer \
+       ltq-vdsl-app ppp-mod-pppoa
 endef
 
-define Profile/EASY80920-NAND/Description
-       Lantiq EASY80920 evalkit (NAND)
+$(eval $(call Profile,EASY80920NOR))
+
+define Profile/EASY80920NAND
+  NAME:=Lantiq VR9 - EASY80920NAND
+  PACKAGES:=kmod-ath9k wpad-mini \
+       kmod-ltq-deu-vr9 kmod-ltq-hcd-vr9 \
+       kmod-ltq-vdsl-vr9-mei kmod-ltq-vdsl-vr9 \
+       kmod-ltq-atm-vr9 ltq-vdsl-vr9-fw-installer \
+       ltq-vdsl-app ppp-mod-pppoa
 endef
 
-$(eval $(call Profile,EASY80920-NAND))
+$(eval $(call Profile,EASY80920NAND))