layerscape: add layerscape's SATA driver package
[openwrt/staging/hauke.git] / target / linux / layerscape / modules.mk
index 5f2d472c95d61a4d05bc8eafd2edc91d6d5b5a3d..4d713b597e8d7b0801b256dbe78fb4ba17c13c21 100644 (file)
@@ -5,6 +5,22 @@
 # See /LICENSE for more information.
 #
 
+define KernelPackage/ahci-qoriq
+  SUBMENU:=$(BLOCK_MENU)
+  TITLE:=Freescale QorIQ AHCI SATA support
+  KCONFIG:=CONFIG_AHCI_QORIQ
+  FILES:=$(LINUX_DIR)/drivers/ata/ahci_qoriq.ko
+  AUTOLOAD:=$(call AutoLoad,40,ahci-qoriq,1)
+  $(call AddDepends/ata,+kmod-ata-ahci-platform @TARGET_layerscape)
+endef
+
+define KernelPackage/ahci-qoriq/description
+ This option enables support for the Freescale QorIQ AHCI SoC's
+ onboard AHCI SATA.
+endef
+
+$(eval $(call KernelPackage,ahci-qoriq))
+
 define KernelPackage/ppfe
   SUBMENU:=$(NETWORK_DEVICES_MENU)
   TITLE:=Freescale PPFE Driver support