kernel: update 4.1 to 4.1.13
[openwrt/staging/yousong.git] / target / linux / mediatek / patches / 0042-ARM-mediatek-add-smp-bringup-code.patch
index 8910532e18d4615836c884b751d5e725c7b90852..c03fb5f6cbea1033ddcb2db8e204310a926c1454 100644 (file)
@@ -13,8 +13,6 @@ Signed-off-by: Yingjoe Chen <yingjoe.chen@mediatek.com>
  2 files changed, 148 insertions(+)
  create mode 100644 arch/arm/mach-mediatek/platsmp.c
 
-diff --git a/arch/arm/mach-mediatek/Makefile b/arch/arm/mach-mediatek/Makefile
-index 43e619f..2116460 100644
 --- a/arch/arm/mach-mediatek/Makefile
 +++ b/arch/arm/mach-mediatek/Makefile
 @@ -1 +1,4 @@
@@ -22,9 +20,6 @@ index 43e619f..2116460 100644
 +obj-$(CONFIG_ARCH_MEDIATEK) += platsmp.o
 +endif
  obj-$(CONFIG_ARCH_MEDIATEK) += mediatek.o
-diff --git a/arch/arm/mach-mediatek/platsmp.c b/arch/arm/mach-mediatek/platsmp.c
-new file mode 100644
-index 0000000..e266b3d
 --- /dev/null
 +++ b/arch/arm/mach-mediatek/platsmp.c
 @@ -0,0 +1,145 @@
@@ -173,6 +168,3 @@ index 0000000..e266b3d
 +      .smp_boot_secondary = mtk_boot_secondary,
 +};
 +CPU_METHOD_OF_DECLARE(mt65xx_smp, "mediatek,mt65xx-smp", &mt65xx_smp_ops);
--- 
-1.7.10.4
-