au1000: add 3.18 support
[openwrt/staging/yousong.git] / target / linux / mpc85xx / Makefile
index 92064d0dcabfa8c5ff83f1fe1c5e4d830bfee140..001de825b666d1913d784e73af0936cd17963bb3 100644 (file)
@@ -9,17 +9,21 @@ include $(TOPDIR)/rules.mk
 ARCH:=powerpc
 BOARD:=mpc85xx
 BOARDNAME:=Freescale MPC85xx
-CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=8540
+CPU_TYPE:=8540
 FEATURES:=spe_fpu squashfs
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
+SUBTARGETS=generic p1020
 
-LINUX_VERSION:=3.7.9
+KERNEL_PATCHVER:=3.14
+
+KERNEL_IMAGES := zImage cuImage.tl-wdr4900-v1
 
 include $(INCLUDE_DIR)/target.mk
 
 DEFAULT_PACKAGES += \
        kmod-input-core kmod-input-gpio-keys kmod-button-hotplug \
-       kmod-booke-wdt swconfig
+       kmod-leds-gpio kmod-booke-wdt \
+       swconfig kmod-ath9k wpad-mini
 
 define Target/Description
        Build images for the Freescale MPC85xx based boards.