[adm8668] move setup-related functions to their own file
[openwrt/svn-archive/archive.git] / target / linux / mpc85xx / Makefile
index 96e7763129ab82daff8e67bc10d6523363d4e2af..1a744ebcc86b8f6554bf24271df2a8a02d1b0a75 100644 (file)
@@ -9,14 +9,16 @@ include $(TOPDIR)/rules.mk
 ARCH:=powerpc
 BOARD:=mpc85xx
 BOARDNAME:=Freescale MPC85xx
-CFLAGS:=-Os -pipe -funit-at-a-time -mcpu=8540
-FEATURES:=fpu ramdisk broken
+CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=8540
+FEATURES:=spe_fpu ramdisk broken
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=2.6.36.1
+LINUX_VERSION:=3.3.8
 
 include $(INCLUDE_DIR)/target.mk
 
+DEFAULT_PACKAGES += kmod-booke-wdt
+
 define Target/Description
        Build images for the Freescale MPC85xx based boards.
 endef