target: use SPDX license identifiers on Makefiles
[openwrt/staging/stintel.git] / target / linux / mpc85xx / Makefile
index 02fdc2f53da6030c983062cf5933311d4adc0cba..b1771dfd8e004dc8a009e4251ce3bd108da08cc7 100644 (file)
@@ -1,9 +1,7 @@
+# SPDX-License-Identifier: GPL-2.0-only
 #
 # Copyright (C) 2010 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
+
 include $(TOPDIR)/rules.mk
 
 ARCH:=powerpc
@@ -11,10 +9,9 @@ BOARD:=mpc85xx
 BOARDNAME:=Freescale MPC85xx
 CPU_TYPE:=8540
 FEATURES:=squashfs ramdisk
-MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
-SUBTARGETS:=generic p1020 p2020
+SUBTARGETS:=p1010 p1020 p2020
 
-KERNEL_PATCHVER:=4.14
+KERNEL_PATCHVER:=5.4
 
 KERNELNAME:=zImage
 
@@ -22,6 +19,6 @@ include $(INCLUDE_DIR)/target.mk
 
 DEFAULT_PACKAGES += \
        kmod-input-core kmod-input-gpio-keys kmod-button-hotplug \
-       kmod-leds-gpio swconfig kmod-ath9k wpad-basic kmod-usb2-fsl
+       kmod-leds-gpio swconfig kmod-ath9k wpad-basic-wolfssl kmod-usb2
 
 $(eval $(call BuildTarget))