target: use SPDX license identifiers on Makefiles
[openwrt/staging/stintel.git] / target / linux / mpc85xx / Makefile
index 1eac544344e566dae8892725417e7ab24eaac749..b1771dfd8e004dc8a009e4251ce3bd108da08cc7 100644 (file)
@@ -1,20 +1,17 @@
+# SPDX-License-Identifier: GPL-2.0-only
 #
 # Copyright (C) 2010 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
+
 include $(TOPDIR)/rules.mk
 
 ARCH:=powerpc
 BOARD:=mpc85xx
 BOARDNAME:=Freescale MPC85xx
 CPU_TYPE:=8540
-FEATURES:=squashfs
-MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
-SUBTARGETS:=generic p1020
+FEATURES:=squashfs ramdisk
+SUBTARGETS:=p1010 p1020 p2020
 
-KERNEL_PATCHVER:=4.14
+KERNEL_PATCHVER:=5.4
 
 KERNELNAME:=zImage
 
@@ -22,6 +19,6 @@ include $(INCLUDE_DIR)/target.mk
 
 DEFAULT_PACKAGES += \
        kmod-input-core kmod-input-gpio-keys kmod-button-hotplug \
-       kmod-leds-gpio swconfig kmod-ath9k wpad-mini
+       kmod-leds-gpio swconfig kmod-ath9k wpad-basic-wolfssl kmod-usb2
 
 $(eval $(call BuildTarget))