target: use SPDX license identifiers on Makefiles
[openwrt/staging/chunkeey.git] / target / linux / mvebu / Makefile
index 6b65eb76e0d83a60462e88740025b74f39be530c..1e67bcfacbaf4e4ce9eb6407ca0b91333e82be1c 100644 (file)
@@ -1,23 +1,19 @@
+# SPDX-License-Identifier: GPL-2.0-only
 #
-# Copyright (C) 2012-2013 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
+# Copyright (C) 2012-2015 OpenWrt.org
+
 include $(TOPDIR)/rules.mk
 
-ARCH:=arm
 BOARD:=mvebu
-BOARDNAME:=Marvell Armada XP/370
-FEATURES:=targz usb pci pcie gpio
-CFLAGS:=-Os -pipe -march=armv7-a -mfpu=vfpv3-d16 -mfloat-abi=softfp
+BOARDNAME:=Marvell EBU Armada
+FEATURES:=fpu usb pci pcie gpio nand squashfs ramdisk boot-part rootfs-part
+SUBTARGETS:=cortexa9 cortexa53 cortexa72
 
-LINUX_VERSION:=3.8.13
+KERNEL_PATCHVER:=5.4
+KERNEL_TESTING_PATCHVER:=5.4
 
 include $(INCLUDE_DIR)/target.mk
 
-KERNELNAME:="zImage dtbs"
-
-DEFAULT_PACKAGES +=
+DEFAULT_PACKAGES += uboot-envtools kmod-gpio-button-hotplug
 
 $(eval $(call BuildTarget))