mvebu: switch to kernel 6.1
[openwrt/staging/jow.git] / target / linux / mvebu / Makefile
index 52e667b7e978bb5c08d96a90ee326339f36661bf..316bf1dfa001c1b1f176c0986bf4cb6dd678a123 100644 (file)
@@ -1,24 +1,18 @@
+# SPDX-License-Identifier: GPL-2.0-only
 #
-# Copyright (C) 2012 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
+# Copyright (C) 2012-2015 OpenWrt.org
+
 include $(TOPDIR)/rules.mk
 
-ARCH:=arm
 BOARD:=mvebu
-BOARDNAME:=Marvell Armada XP/370 boards
-FEATURES:=targz usb jffs2 pci pcie gpio
-CFLAGS:=-Os -pipe -march=armv7-a -mfpu=vfpv3-d16 -mfloat-abi=softfp
-MAINTAINER:=Florian Fainelli <florian@openwrt.org>
+BOARDNAME:=Marvell EBU Armada
+FEATURES:=fpu usb pci pcie gpio nand squashfs ramdisk boot-part rootfs-part legacy-sdcard targz
+SUBTARGETS:=cortexa9 cortexa53 cortexa72
 
-LINUX_VERSION:=3.8-rc6
+KERNEL_PATCHVER:=6.1
 
 include $(INCLUDE_DIR)/target.mk
 
-KERNELNAME:="zImage dtbs"
-
-DEFAULT_PACKAGES +=
+DEFAULT_PACKAGES += uboot-envtools kmod-gpio-button-hotplug
 
 $(eval $(call BuildTarget))