mvebu: make bootfs size for sdcard image configurable
[openwrt/staging/ynezz.git] / target / linux / mvebu / Makefile
index dc61e7c2c170894956c5ac32db8b7d7ab82f2602..a920f6db7d480c2277de38b576b768f4be3d1768 100644 (file)
@@ -1,25 +1,21 @@
 #
-# Copyright (C) 2012-2014 OpenWrt.org
+# Copyright (C) 2012-2015 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 include $(TOPDIR)/rules.mk
 
-ARCH:=arm
 BOARD:=mvebu
-BOARDNAME:=Marvell Armada XP/370
-FEATURES:=targz usb pci pcie gpio nand squashfs
-CPU_TYPE:=cortex-a9
-CPU_SUBTYPE:=vfpv3
-MAINTAINER:=Luka Perkov <luka@openwrt.org>
+BOARDNAME:=Marvell EBU Armada
+FEATURES:=fpu usb pci pcie gpio nand squashfs ramdisk boot-part rootfs-part
+SUBTARGETS:=cortexa9 cortexa53 cortexa72
+MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=3.14.18
+KERNEL_PATCHVER:=4.14
 
 include $(INCLUDE_DIR)/target.mk
 
-KERNELNAME:=zImage dtbs
-
-DEFAULT_PACKAGES += uboot-envtools
+DEFAULT_PACKAGES += uboot-envtools kmod-gpio-button-hotplug
 
 $(eval $(call BuildTarget))