mvebu: initial support for Marvell Armada 3720 DB board
[openwrt/staging/lynxis.git] / target / linux / mvebu / image / cortex-a53.mk
index 711d2c0be855de6a7ab06d76055396ca8e1d120f..89c33634482ed110468b52ff69521f3cfb9ef90e 100644 (file)
@@ -13,4 +13,17 @@ define Device/globalscale-espressobin
 endef
 TARGET_DEVICES += globalscale-espressobin
 
+define Device/armada-3720-db
+  KERNEL_NAME := Image
+  KERNEL := kernel-bin
+  DEVICE_TITLE := Marvell Armada 3720 Development Board DB-88F3720-DDR3
+  DEVICE_PACKAGES := e2fsprogs ethtool mkf2fs kmod-fs-vfat kmod-usb2 kmod-usb3 kmod-usb-storage
+  IMAGES := sdcard.img.gz
+  IMAGE/sdcard.img.gz := boot-scr | boot-img-ext4 | sdcard-img-ext4 | gzip | append-metadata
+  DEVICE_DTS := armada-3720-db
+  DTS_DIR := $(DTS_DIR)/marvell
+  SUPPORTED_DEVICES := marvell,armada-3720-db
+endef
+TARGET_DEVICES += armada-3720-db
+
 endif