build: add a config option for enabling a testing version of the target kernel
[openwrt/staging/jow.git] / target / linux / octeon / Makefile
index ea005d01f6a49ace9476161d3d58a142f8e29860..202ed39be7376e50e014784b12976c717d60cff3 100644 (file)
@@ -6,20 +6,22 @@
 #
 include $(TOPDIR)/rules.mk
 
-ARCH:=mips
+ARCH:=mips64
 BOARD:=octeon
 BOARDNAME:=Cavium Networks Octeon
-FEATURES:=squashfs jffs2 pci usb
-CFLAGS:=-Os -pipe -march=octeon -fno-caller-saves
-MAINTAINER:=John Crispin <blogic@openwrt.org>
-
-LINUX_VERSION:=3.10
-
-include $(INCLUDE_DIR)/target.mk
+FEATURES:=squashfs ramdisk pci usb
+CPU_TYPE:=octeonplus
+MAINTAINER:=John Crispin <john@phrozen.org>
 
+KERNEL_PATCHVER:=4.14
+KERNEL_TESTING_PATCHVER := 4.19
 
 define Target/Description
        Build firmware images for Cavium Networks Octeon-based boards.
 endef
 
+include $(INCLUDE_DIR)/target.mk
+
+DEFAULT_PACKAGES += mkf2fs e2fsprogs
+
 $(eval $(call BuildTarget))