mvebu: enable NEON support
[openwrt/staging/wigyori.git] / target / linux / octeon / Makefile
index 20b3510ab53cff8a874d815a3b250353f5676bd1..5cddd2de854469c1d52c18e944abe54869097ad4 100644 (file)
@@ -1,22 +1,22 @@
 #
-# Copyright (C) 2009 OpenWrt.org
+# Copyright (C) 2013 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 include $(TOPDIR)/rules.mk
 
-ARCH:=mips
+ARCH:=mips64
 BOARD:=octeon
 BOARDNAME:=Cavium Networks Octeon
-FEATURES:=squashfs jffs2 pci
-CFLAGS:=-Os -pipe -funit-at-a-time
+FEATURES:=squashfs ext4 initramfs pci usb
+CPU_TYPE:=octeon
+MAINTAINER:=John Crispin <john@phrozen.org>
 
-LINUX_VERSION:=2.6.30.3
+KERNEL_PATCHVER:=4.4
 
 include $(INCLUDE_DIR)/target.mk
 
-DEFAULT_PACKAGES += hostapd-mini
 
 define Target/Description
        Build firmware images for Cavium Networks Octeon-based boards.