octeon: add support for the octeon mips64 SoC
[openwrt/staging/chunkeey.git] / target / linux / octeon / Makefile
index 236a97f1d0818f14464ae4c36042fe912532dcc5..ea005d01f6a49ace9476161d3d58a142f8e29860 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2009-2011 OpenWrt.org
+# Copyright (C) 2013 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -10,13 +10,13 @@ ARCH:=mips
 BOARD:=octeon
 BOARDNAME:=Cavium Networks Octeon
 FEATURES:=squashfs jffs2 pci usb
-CFLAGS:=-Os -pipe -march=octeon -funit-at-a-time
+CFLAGS:=-Os -pipe -march=octeon -fno-caller-saves
+MAINTAINER:=John Crispin <blogic@openwrt.org>
 
-LINUX_VERSION:=2.6.37.4
+LINUX_VERSION:=3.10
 
 include $(INCLUDE_DIR)/target.mk
 
-DEFAULT_PACKAGES += wpad-mini
 
 define Target/Description
        Build firmware images for Cavium Networks Octeon-based boards.