omap: take over maintainership
[openwrt/staging/yousong.git] / target / linux / omap / Makefile
index dcab026114ffa35845735f57506a2579b943f1c8..21a312a4b7b583b102c4d5d1431a1f63550daed2 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2012-2013 OpenWrt.org
+# Copyright (C) 2012-2014 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,22 +9,20 @@ include $(TOPDIR)/rules.mk
 ARCH:=arm
 BOARD:=omap
 BOARDNAME:=TI OMAP3/4/AM33xx
-FEATURES:=usb targz audio display
+FEATURES:=usb usbgadget ext4 targz fpu audio display nand ubifs
 CPU_TYPE:=cortex-a9
 CPU_SUBTYPE:=vfpv3
 
-LINUX_VERSION:=3.12
+KERNEL_PATCHVER:=3.18
 
-MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
+MAINTAINER:=Alexander Couzens <lynxis@fe80.eu>
 
-KERNELNAME:="zImage dtbs"
+KERNELNAME:=zImage dtbs
 
 include $(INCLUDE_DIR)/target.mk
 
 DEFAULT_PACKAGES += uboot-omap-am335x_evm uboot-omap-omap3_beagle uboot-omap-omap3_overo uboot-omap-omap4_panda
 
-DEVICE_TYPE=developerboard
-
 define Target/Description
        TI OMAP boards
 endef