ocf: switch MODULE_LICENSE from BSD to "Dual BSD/GPL" to make the kernel recognize...
[openwrt/svn-archive/archive.git] / target / linux / omap24xx / Makefile
index 0f8e05344dbc93eb8d75724550cea1f93540d313..b3e54d31be0ea754e87007cf77f2c7e22a08155b 100644 (file)
@@ -8,16 +8,20 @@ include $(TOPDIR)/rules.mk
 
 ARCH:=arm
 BOARD:=omap24xx
-BOARDNAME:=TI OMAP-24xx
-MAINTAINER:=Michael Buesch <mb@bu3sch.de>
-FEATURES:=targz squashfs jffs2 usb usbgadget display gpio audio
+BOARDNAME:=TI OMAP24xx
+MAINTAINER:=Michael Buesch <m@bues.ch>
+FEATURES:=targz squashfs jffs2_nand usb usbgadget display gpio audio broken
 
-LINUX_VERSION:=2.6.38-rc7
+LINUX_VERSION:=3.3.8
 
 define Target/Description
        TI OMAP-24xx
 endef
 
+CFLAGS:=-Os -pipe -march=armv6 -mtune=arm1136j-s
+
+KERNELNAME:="zImage"
+
 include $(INCLUDE_DIR)/target.mk
 
 $(eval $(call BuildTarget))