kernel/3.10: add a generic patch for cpu_has_mmips override
[openwrt/svn-archive/archive.git] / target / linux / ppc40x / Makefile
index 44a4af86f2a7ba14a9fc957db9e6c3e51368227c..39b074a5c73a82593a6546a10b57dbe89c0ef84f 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2008 OpenWrt.org
+# Copyright (C) 2008-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -10,14 +10,17 @@ ARCH:=powerpc
 BOARD:=ppc40x
 BOARDNAME:=AMCC/IBM PPC40x
 FEATURES:=squashfs
+CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=405
+MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=2.6.27.8
-LINUX_KARCH:=powerpc
+LINUX_VERSION:=3.8.13
 
 include $(INCLUDE_DIR)/target.mk
 
 define Target/Description
-       Build firmware images for the AMCC Kilauea evaluation board
+       Build firmware images for AMCC/IBM PPC40x based boards.
 endef
 
+KERNELNAME:="uImage cuImage.magicbox cuImage.openrb"
+
 $(eval $(call BuildTarget))