kernel: update 3.10 to 3.10.28
[openwrt/staging/stintel.git] / target / linux / ppc40x / Makefile
index 5c9ef3e38b892b14a54a0a15edda65042718b15e..98caa11d84bdcccf03b151e88b94edeed2b3fdc5 100644 (file)
@@ -10,10 +10,10 @@ ARCH:=powerpc
 BOARD:=ppc40x
 BOARDNAME:=AMCC/IBM PPC40x
 FEATURES:=squashfs
-CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=405
+CPU_TYPE:=405
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=3.8.2
+LINUX_VERSION:=3.10.28
 
 include $(INCLUDE_DIR)/target.mk
 
@@ -21,4 +21,6 @@ define Target/Description
        Build firmware images for AMCC/IBM PPC40x based boards.
 endef
 
+KERNELNAME:="uImage cuImage.magicbox cuImage.openrb"
+
 $(eval $(call BuildTarget))