kernel: preserve oif of IPv6 link scope packets
[openwrt/staging/dedeckeh.git] / target / linux / ppc40x / Makefile
index 2efb13a8defeee3c50c081d24f6c07716ef30fe7..ebe09988a8e1f90d26c4a7bae0ac189378d193fd 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2008-2011 OpenWrt.org
+# Copyright (C) 2008-2015 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,16 +9,18 @@ include $(TOPDIR)/rules.mk
 ARCH:=powerpc
 BOARD:=ppc40x
 BOARDNAME:=AMCC/IBM PPC40x
-FEATURES:=squashfs
-CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=405
+FEATURES:=squashfs small_flash broken
+CPU_TYPE:=405
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=3.0.18
-
-include $(INCLUDE_DIR)/target.mk
+KERNEL_PATCHVER:=3.18
 
 define Target/Description
        Build firmware images for AMCC/IBM PPC40x based boards.
 endef
 
+include $(INCLUDE_DIR)/target.mk
+
+KERNELNAME:=uImage cuImage.magicbox cuImage.openrb
+
 $(eval $(call BuildTarget))