realview: remove 3.0 support
[openwrt/svn-archive/archive.git] / target / linux / ppc44x / Makefile
index 8ba42d80eaac15c9fc9968163e05e4d59db7b64d..e5758343457b18e276f88cd400911645c37f86b5 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2007-2010 OpenWrt.org
+# Copyright (C) 2007-2012 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -10,12 +10,15 @@ ARCH:=powerpc
 BOARD:=ppc44x
 BOARDNAME:=AMCC/IBM PPC44x
 FEATURES:=squashfs
-CFLAGS:=-Os -pipe -funit-at-a-time -mcpu=440
+CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=440
+MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=2.6.32.8
+LINUX_VERSION:=3.2.16
 
 include $(INCLUDE_DIR)/target.mk
 
+DEFAULT_PACKAGES := $(filter-out ppp%,$(DEFAULT_PACKAGES))
+
 define Target/Description
        Build firmware images for AMCC/IBM PPC44x based boards.
 endef