update to 2.6.32.33 and 2.6.37.4
[openwrt/staging/lynxis/omap.git] / target / linux / pxa / Makefile
index 7bf4c38f1cd3524e2c25dce72919c754b007dd26..32bb77d6e06685ea215336df5e6e2ba84d2246a9 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,15 +8,18 @@ include $(TOPDIR)/rules.mk
 
 ARCH:=arm
 BOARD:=pxa
-BOARDNAME:=PXA
-FEATURES:=jffs2 broken
+BOARDNAME:=Marvell/Intel PXA2xx
+FEATURES:=squashfs
+MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=2.6.21.7
+LINUX_VERSION:=2.6.37.4
 
 include $(INCLUDE_DIR)/target.mk
 
 define Target/Description
-       Stub for boards based on intel PXA
+       Build images for PXA2xx systems, eg. Gumstix.
 endef
 
+KERNELNAME:="uImage"
+
 $(eval $(call BuildTarget))