qualcommax: ipq807x: alphabetically sort Netgear WAX family.
[openwrt/staging/hauke.git] / target / linux / qualcommax / image / ipq807x.mk
index b61b721f3a4f557337bddf402b404f47ec8f9297..c0f15f3c83927a903e51b60b611e68baa95fcc1f 100644 (file)
@@ -115,36 +115,36 @@ define Device/netgear_rax120v2
 endef
 TARGET_DEVICES += netgear_rax120v2
 
-define Device/netgear_wax620
+define Device/netgear_wax218
        $(call Device/FitImage)
        $(call Device/UbiFit)
+       ARTIFACTS := web-ui-factory.fit
        DEVICE_VENDOR := Netgear
-       DEVICE_MODEL := WAX620
+       DEVICE_MODEL := WAX218
        DEVICE_DTS_CONFIG := config@hk07
        BLOCKSIZE := 128k
        PAGESIZE := 2048
        SOC := ipq8072
-       DEVICE_PACKAGES += kmod-spi-gpio kmod-gpio-nxp-74hc164 \
-               ipq-wifi-netgear_wax620
+       ARTIFACT/web-ui-factory.fit := append-image initramfs-uImage.itb | \
+               ubinize-kernel | qsdk-ipq-factory-nand
+       DEVICE_PACKAGES := kmod-spi-gpio kmod-spi-bitbang kmod-gpio-nxp-74hc164 \
+               ipq-wifi-netgear_wax218
 endef
-TARGET_DEVICES += netgear_wax620
+TARGET_DEVICES += netgear_wax218
 
-define Device/netgear_wax218
+define Device/netgear_wax620
        $(call Device/FitImage)
        $(call Device/UbiFit)
-       ARTIFACTS := web-ui-factory.fit
        DEVICE_VENDOR := Netgear
-       DEVICE_MODEL := WAX218
+       DEVICE_MODEL := WAX620
        DEVICE_DTS_CONFIG := config@hk07
        BLOCKSIZE := 128k
        PAGESIZE := 2048
        SOC := ipq8072
-       ARTIFACT/web-ui-factory.fit := append-image initramfs-uImage.itb | \
-               ubinize-kernel | qsdk-ipq-factory-nand
-       DEVICE_PACKAGES := kmod-spi-gpio kmod-spi-bitbang kmod-gpio-nxp-74hc164 \
-               ipq-wifi-netgear_wax218
+       DEVICE_PACKAGES += kmod-spi-gpio kmod-gpio-nxp-74hc164 \
+               ipq-wifi-netgear_wax620
 endef
-TARGET_DEVICES += netgear_wax218
+TARGET_DEVICES += netgear_wax620
 
 define Device/prpl_haze
        $(call Device/FitImage)