ramips: fix typo in default packages
[openwrt/staging/lynxis/omap.git] / target / linux / ramips / Makefile
index 8eac4f6ef3a08839452dd05110222fd6f82dad6d..bfe663ec9a1940f412f0fff412a0f007fcd4070f 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2008-2009 OpenWrt.org
+# Copyright (C) 2008-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -10,13 +10,15 @@ ARCH:=mipsel
 BOARD:=ramips
 BOARDNAME:=Ralink RT288x/RT305x
 SUBTARGETS:=rt288x rt305x
-CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -funit-at-a-time
-FEATURES:=squashfs broken
+CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves
+FEATURES:=squashfs
 
-LINUX_VERSION:=2.6.32.10
+LINUX_VERSION:=2.6.39.4
 
 include $(INCLUDE_DIR)/target.mk
-DEFAULT_PACKAGES+=kmod-leds-gpio
+DEFAULT_PACKAGES+=\
+       kmod-leds-gpio kmod-input-core kmod-input-polldev kmod-gpio-buttons \
+       kmod-button-hotplug wpad-mini maccalc
 
 define Target/Description
        Build firmware images for Ralink RT288x/RT305x based boards.