kernel: update linux 3.8 to 3.8.12
[openwrt/staging/jow.git] / target / linux / ramips / Makefile
index 85279d50d8cca1734a68aaca79f877fae49eb53c..d4ad0c4032c9f2830bb1138b32f6659b9b57b504 100644 (file)
@@ -8,21 +8,21 @@ include $(TOPDIR)/rules.mk
 
 ARCH:=mipsel
 BOARD:=ramips
-BOARDNAME:=Ralink RT288x/RT305x
-SUBTARGETS:=rt288x rt305x
-CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves
-FEATURES:=squashfs
+BOARDNAME:=Ralink RT288x/RT3xxx
+SUBTARGETS:=rt288x rt305x rt3883
+CFLAGS:=-Os -pipe -fno-caller-saves -mno-branch-likely
+FEATURES:=squashfs gpio
 
-LINUX_VERSION:=3.2.5
+LINUX_VERSION:=3.8.12
 
 include $(INCLUDE_DIR)/target.mk
 DEFAULT_PACKAGES+=\
        kmod-leds-gpio kmod-input-core kmod-input-polldev \
        kmod-input-gpio-keys-polled kmod-button-hotplug \
-       kmod-rt2800-pci wpad-mini maccalc
+       kmod-rt2800-pci wpad-mini swconfig
 
 define Target/Description
-       Build firmware images for Ralink RT288x/RT305x based boards.
+       Build firmware images for Ralink RT288x/RT3xxx based boards.
 endef
 
 $(eval $(call BuildTarget))