treewide: gpio-export: add error handling
[openwrt/staging/wigyori.git] / target / linux / ramips / image / mt7620.mk
index 8081d906f6be9c6fb2cc21a2a8640369626f7ff2..325e3104a7e43335316cd4c075bc8830c31e3a8e 100644 (file)
@@ -431,6 +431,14 @@ define Device/psg1218b
 endef
 TARGET_DEVICES += psg1218b
 
+define Device/phicomm_k2g
+  DTS := K2G
+  IMAGE_SIZE := 7552k
+  DEVICE_TITLE := Phicomm K2G
+  DEVICE_PACKAGES := kmod-mt76x2
+endef
+TARGET_DEVICES += phicomm_k2g
+
 define Device/rp-n53
   DTS := RP-N53
   DEVICE_TITLE := Asus RP-N53
@@ -464,6 +472,18 @@ define Device/tiny-ac
 endef
 TARGET_DEVICES += tiny-ac
 
+define Device/tplink_c2-v1
+  $(Device/Archer)
+  DTS := ArcherC2-v1
+  TPLINK_FLASHLAYOUT := 8Mmtk
+  TPLINK_HWID := 0xc7500001
+  TPLINK_HWREV := 50
+  IMAGES += factory.bin
+  DEVICE_TITLE := TP-Link Archer C2 v1
+  DEVICE_PACKAGES := kmod-usb2 kmod-usb-ohci kmod-usb-ledtrig-usbport kmod-switch-rtl8366-smi kmod-switch-rtl8367b
+endef
+TARGET_DEVICES += tplink_c2-v1
+
 define Device/tplink_c20-v1
   $(Device/Archer)
   DTS := ArcherC20v1