ramips: Add support for ZTE ZXECS EBG3130 aka BDCOM WAP2100-SK
[openwrt/staging/jow.git] / target / linux / ramips / image / mt7620.mk
index b5d73f60c7e804239eae84c880984812ee570393..61a6e56937a565351407041fae7f9a5a8679ef6e 100644 (file)
@@ -80,6 +80,15 @@ define Device/ArcherMR200
 endef
 TARGET_DEVICES += ArcherMR200
 
+define Device/BDCOM-WAP2100-SK
+  DTS := BDCOM-WAP2100-SK
+  IMAGE_SIZE := $(ralink_default_fw_size_16M)
+  SUPPORTED_DEVICES += wap2100-sk
+  DEVICE_TITLE := BDCOM WAP2100-SK (ZTE ZXECS EBG3130)
+  DEVICE_PACKAGES := kmod-usb2 kmod-usb-ohci kmod-mt76 kmod-sdhci-mt7620
+endef
+TARGET_DEVICES += BDCOM-WAP2100-SK
+
 define Device/bocco
   DTS := BOCCO
   DEVICE_TITLE := YUKAI Engineering BOCCO