Revert "ramips: add support for ipTIME AX2004M"
[openwrt/staging/jow.git] / target / linux / ramips / image / mt7621.mk
index 46097f231eac2864c09de4cc68ebecc582cd60a1..a461c57f1508383680cfe074aba5b9053842e953 100644 (file)
@@ -785,6 +785,17 @@ define Device/iptime_a3004t
 endef
 TARGET_DEVICES += iptime_a3004t
 
+define Device/iptime_a6004ns-m
+  $(Device/dsa-migration)
+  IMAGE_SIZE := 16128k
+  UIMAGE_NAME := a6004nm
+  DEVICE_VENDOR := ipTIME
+  DEVICE_MODEL := A6004NS-M
+  DEVICE_PACKAGES := kmod-mt7615e kmod-mt7615-firmware kmod-usb3 \
+        kmod-usb-ledtrig-usbport
+endef
+TARGET_DEVICES += iptime_a6004ns-m
+
 define Device/iptime_a6ns-m
   $(Device/dsa-migration)
   IMAGE_SIZE := 16128k
@@ -912,6 +923,15 @@ define Device/linksys_ea7xxx
        append-ubi | check-size | linksys-image type=$$$$(LINKSYS_HWNAME)
 endef
 
+define Device/linksys_ea6350-v4
+       $(Device/linksys_ea7xxx)
+       DEVICE_MODEL := EA6350
+       DEVICE_VARIANT := v4
+       LINKSYS_HWNAME := EA6350
+       DEVICE_PACKAGES += kmod-mt7603 kmod-mt7663-firmware-ap
+endef
+TARGET_DEVICES += linksys_ea6350-v4
+
 define Device/linksys_ea7300-v1
   $(Device/linksys_ea7xxx)
   DEVICE_MODEL := EA7300