ramips: tl-wr840n-v5: increase firmware partition for 4Mmtk layot
[openwrt/staging/ynezz.git] / target / linux / ramips / image / mt76x8.mk
index 8bbbcf6ad916abb9c396381db431fec5ad398775..8332c7c4233d06f61fc5f3984cf2a282b8f7863c 100644 (file)
@@ -112,7 +112,7 @@ TARGET_DEVICES += tl-wr840n-v4
 
 define Device/tl-wr840n-v5
   DTS := TL-WR840NV5
-  IMAGE_SIZE := 3840k
+  IMAGE_SIZE := 3904k
   DEVICE_TITLE := TP-Link TL-WR840N v5
   TPLINK_FLASHLAYOUT := 4Mmtk
   TPLINK_HWID := 0x08400005
@@ -139,6 +139,19 @@ define Device/tl-wr841n-v13
 endef
 TARGET_DEVICES += tl-wr841n-v13
 
+define Device/tplink_c20-v4
+  $(Device/tplink)
+  DTS := ArcherC20v4
+  IMAGE_SIZE := 7808k
+  DEVICE_TITLE := TP-Link ArcherC20 v4
+  TPLINK_FLASHLAYOUT := 8Mmtk
+  TPLINK_HWID := 0xc200004
+  TPLINK_HWREV := 0x1
+  TPLINK_HWREVADD := 0x4
+  TPLINK_HVERSION := 3
+endef
+TARGET_DEVICES += tplink_c20-v4
+
 define Device/tplink_tl-mr3420-v5
   $(Device/tplink)
   DTS := TL-MR3420V5