ramips/rt288x,rt3883: Synchronize Makefiles with DTS compatible
[openwrt/staging/chunkeey.git] / target / linux / ramips / image / rt288x.mk
index 22fe4a857a25a5b35751dec08a2cce9867c1ecc7..fe6764ce59a9d277c9c62ed3b0ddec2b97a705d3 100644 (file)
@@ -9,7 +9,7 @@ define Build/gemtek-header
        fi
 endef
 
-define Device/ar670w
+define Device/airlink101_ar670w
   DTS := AR670W
   BLOCKSIZE := 64k
   DEVICE_VENDOR := Airlink
@@ -19,18 +19,20 @@ define Device/ar670w
   IMAGES += factory.bin
   IMAGE/factory.bin := $$(sysupgrade_bin) | check-size $$$$(IMAGE_SIZE) | \
        wrg-header wrgn16a_airlink_ar670w
+  SUPPORTED_DEVICES += ar670w
 endef
-TARGET_DEVICES += ar670w
+TARGET_DEVICES += airlink101_ar670w
 
-define Device/ar725w
+define Device/airlink101_ar725w
   DTS := AR725W
   DEVICE_VENDOR := Airlink
   DEVICE_MODEL := AR725W
   IMAGES += factory.bin
   IMAGE/factory.bin := $$(sysupgrade_bin) | check-size 3328k | \
        gemtek-header ar725w
+  SUPPORTED_DEVICES += ar725w
 endef
-TARGET_DEVICES += ar725w
+TARGET_DEVICES += airlink101_ar725w
 
 define Device/dlink_dap-1522-a1
   DTS := DAP-1522-A1
@@ -50,7 +52,7 @@ define Device/dlink_dap-1522-a1
 endef
 TARGET_DEVICES += dlink_dap-1522-a1
 
-define Device/f5d8235-v1
+define Device/belkin_f5d8235-v1
   DTS := F5D8235_V1
   IMAGE_SIZE := 7744k
   DEVICE_VENDOR := Belkin
@@ -58,44 +60,49 @@ define Device/f5d8235-v1
   DEVICE_VARIANT := V1
   DEVICE_PACKAGES := kmod-switch-rtl8366s kmod-usb-core kmod-usb-ohci \
     kmod-usb-ohci-pci kmod-usb2 kmod-usb2-pci kmod-usb-ledtrig-usbport
+  SUPPORTED_DEVICES += f5d8235-v1
 endef
-TARGET_DEVICES += f5d8235-v1
+TARGET_DEVICES += belkin_f5d8235-v1
 
-define Device/rt-n15
+define Device/asus_rt-n15
   DTS := RT-N15
   BLOCKSIZE := 64k
   IMAGE_SIZE := $(ralink_default_fw_size_4M)
   DEVICE_VENDOR := Asus
   DEVICE_MODEL := RT-N15
   DEVICE_PACKAGES := kmod-switch-rtl8366s
+  SUPPORTED_DEVICES += rt-n15
 endef
-TARGET_DEVICES += rt-n15
+TARGET_DEVICES += asus_rt-n15
 
-define Device/v11st-fe
+define Device/ralink_v11st-fe
   DTS := V11STFE
   BLOCKSIZE := 64k
   IMAGE_SIZE := $(ralink_default_fw_size_4M)
   DEVICE_VENDOR := Ralink
   DEVICE_MODEL := V11ST-FE
+  SUPPORTED_DEVICES += v11st-fe
 endef
-TARGET_DEVICES += v11st-fe
+TARGET_DEVICES += ralink_v11st-fe
 
-define Device/wli-tx4-ag300n
+define Device/buffalo_wli-tx4-ag300n
   DTS := WLI-TX4-AG300N
   BLOCKSIZE := 64k
   IMAGE_SIZE := $(ralink_default_fw_size_4M)
   DEVICE_VENDOR := Buffalo
   DEVICE_MODEL := WLI-TX4-AG300N
   DEVICE_PACKAGES := kmod-switch-ip17xx
+  SUPPORTED_DEVICES += wli-tx4-ag300n
 endef
-TARGET_DEVICES += wli-tx4-ag300n
+TARGET_DEVICES += buffalo_wli-tx4-ag300n
 
-define Device/wzr-agl300nh
+define Device/buffalo_wzr-agl300nh
   DTS := WZR-AGL300NH
   BLOCKSIZE := 64k
   IMAGE_SIZE := $(ralink_default_fw_size_4M)
   DEVICE_VENDOR := Buffalo
   DEVICE_MODEL := WZR-AGL300NH
   DEVICE_PACKAGES := kmod-switch-rtl8366s
+  SUPPORTED_DEVICES += wzr-agl300nh
 endef
-TARGET_DEVICES += wzr-agl300nh
+TARGET_DEVICES += buffalo_wzr-agl300nh