ramips: add om-watchdog to rut5xx DEVICE_PACKAGES
[openwrt/openwrt.git] / target / linux / ramips / image / rt305x.mk
index 69533ce9e78f802020f5ee9d530ca6a3576f2284..5876dcb986bca0fde31b4d94f411f85d7cdd03d3 100644 (file)
@@ -639,6 +639,7 @@ TARGET_DEVICES += rt-n13u
 define Device/rut5xx
   DTS := RUT5XX
   DEVICE_TITLE := Teltonika RUT5XX
+  DEVICE_PACKAGES := om-watchdog
 endef
 TARGET_DEVICES += rut5xx
 
@@ -850,3 +851,12 @@ define Device/xdxrn502j
   DEVICE_TITLE := XDX RN502J
 endef
 TARGET_DEVICES += xdxrn502j
+
+define Device/kn
+  DTS := kn
+  BLOCKSIZE := 64k
+  IMAGE_SIZE := $(ralink_default_fw_size_4M)
+  DEVICE_TITLE := ZyXEL Keenetic
+  DEVICE_PACKAGES := kmod-usb-core kmod-usb2 kmod-usb-ehci kmod-usb-ledtrig-usbport
+endef
+TARGET_DEVICES += kn