ramips: tidy up image subtarget Makefiles
[openwrt/staging/stintel.git] / target / linux / ramips / image / rt3883.mk
index ca6a713c4d4865c62cb02bbbf3f56d6b9fa104f1..8f4c22097b458919c8327066b705afd25627b1a1 100644 (file)
@@ -12,7 +12,7 @@ define Device/asus_rt-n56u
   IMAGE/sysupgrade.bin += | mkrtn56uimg -s
   DEVICE_VENDOR := Asus
   DEVICE_MODEL := RT-N56U
-  DEVICE_PACKAGES := kmod-usb-ohci kmod-usb2 swconfig
+  DEVICE_PACKAGES := kmod-usb-ohci kmod-usb2
   SUPPORTED_DEVICES += rt-n56u
 endef
 TARGET_DEVICES += asus_rt-n56u
@@ -23,7 +23,7 @@ define Device/belkin_f9k1109v1
   DEVICE_VENDOR := Belkin
   DEVICE_MODEL := F9K1109
   DEVICE_VARIANT := Version 1.0
-  DEVICE_PACKAGES := kmod-usb-ohci kmod-usb2 swconfig
+  DEVICE_PACKAGES := kmod-usb-ohci kmod-usb2 kmod-usb-ledtrig-usbport
   IMAGE_SIZE := 7808k
   KERNEL := kernel-bin | append-dtb | lzma -d16 | uImage lzma
   # Stock firmware checks for this uImage image name during upload.
@@ -40,7 +40,7 @@ define Device/dlink_dir-645
   SEAMA_SIGNATURE := wrgn39_dlob.hans_dir645
   DEVICE_VENDOR := D-Link
   DEVICE_MODEL := DIR-645
-  DEVICE_PACKAGES := kmod-usb-ohci kmod-usb2 swconfig
+  DEVICE_PACKAGES := kmod-usb-ohci kmod-usb2
   SUPPORTED_DEVICES += dir-645
 endef
 TARGET_DEVICES += dlink_dir-645
@@ -51,10 +51,9 @@ define Device/edimax_br-6475nd
   IMAGE_SIZE := 7744k
   IMAGE/sysupgrade.bin := append-kernel | append-rootfs | \
        edimax-header -s CSYS -m RN54 -f 0x70000 -S 0x01100000 | pad-rootfs | \
-       append-metadata | check-size $$$$(IMAGE_SIZE)
+       append-metadata | check-size
   DEVICE_VENDOR := Edimax
   DEVICE_MODEL := BR-6475nD
-  DEVICE_PACKAGES := swconfig
   SUPPORTED_DEVICES += br-6475nd
 endef
 TARGET_DEVICES += edimax_br-6475nd
@@ -89,7 +88,7 @@ define Device/samsung_cy-swr1100
   SEAMA_SIGNATURE := wrgnd10_samsung_ss815
   DEVICE_VENDOR := Samsung
   DEVICE_MODEL := CY-SWR1100
-  DEVICE_PACKAGES := kmod-usb-ohci kmod-usb2 kmod-usb-ledtrig-usbport swconfig
+  DEVICE_PACKAGES := kmod-usb-ohci kmod-usb2 kmod-usb-ledtrig-usbport
   SUPPORTED_DEVICES += cy-swr1100
 endef
 TARGET_DEVICES += samsung_cy-swr1100
@@ -99,11 +98,11 @@ define Device/sitecom_wlr-6000
   BLOCKSIZE := 4k
   IMAGE_SIZE := 7244k
   IMAGES += factory.dlf
-  IMAGE/factory.dlf := $$(sysupgrade_bin) | check-size $$$$(IMAGE_SIZE) | \
+  IMAGE/factory.dlf := $$(sysupgrade_bin) | check-size | \
        senao-header -r 0x0202 -p 0x41 -t 2
   DEVICE_VENDOR := Sitecom
   DEVICE_MODEL := WLR-6000
-  DEVICE_PACKAGES := kmod-usb-ohci kmod-usb2 swconfig
+  DEVICE_PACKAGES := kmod-usb-ohci kmod-usb2
   SUPPORTED_DEVICES += wlr-6000
 endef
 TARGET_DEVICES += sitecom_wlr-6000
@@ -113,11 +112,9 @@ define Device/trendnet_tew-691gr
   BLOCKSIZE := 64k
   IMAGE_SIZE := 7872k
   IMAGES += factory.bin
-  IMAGE/factory.bin := $$(sysupgrade_bin) | check-size $$$$(IMAGE_SIZE) | \
-       umedia-header 0x026910
+  IMAGE/factory.bin := $$(sysupgrade_bin) | check-size | umedia-header 0x026910
   DEVICE_VENDOR := TRENDnet
   DEVICE_MODEL := TEW-691GR
-  DEVICE_PACKAGES := swconfig
   SUPPORTED_DEVICES += tew-691gr
 endef
 TARGET_DEVICES += trendnet_tew-691gr
@@ -127,11 +124,9 @@ define Device/trendnet_tew-692gr
   BLOCKSIZE := 64k
   IMAGE_SIZE := 7872k
   IMAGES += factory.bin
-  IMAGE/factory.bin := $$(sysupgrade_bin) | check-size $$$$(IMAGE_SIZE) | \
-       umedia-header 0x026920
+  IMAGE/factory.bin := $$(sysupgrade_bin) | check-size | umedia-header 0x026920
   DEVICE_VENDOR := TRENDnet
   DEVICE_MODEL := TEW-692GR
-  DEVICE_PACKAGES := swconfig
   SUPPORTED_DEVICES += tew-692gr
 endef
 TARGET_DEVICES += trendnet_tew-692gr