ramips: convert DEVICE_TITLE to new variables
[openwrt/staging/blogic.git] / target / linux / ramips / image / rt3883.mk
index 973eab9a64901c8320707de09521729251d20932..b360a2d664a18745529d9275419b8ba02eba7f30 100644 (file)
@@ -12,58 +12,58 @@ define Device/br-6475nd
   IMAGE/sysupgrade.bin := append-kernel | append-rootfs | \
        edimax-header -s CSYS -m RN54 -f 0x70000 -S 0x01100000 | pad-rootfs | \
        append-metadata | check-size $$$$(IMAGE_SIZE)
-  DEVICE_TITLE := Edimax BR-6475nD
+  DEVICE_VENDOR := Edimax
+  DEVICE_MODEL := BR-6475nD
   DEVICE_PACKAGES := swconfig
 endef
 TARGET_DEVICES += br-6475nd
 
 define Device/cy-swr1100
+  $(Device/seama)
   DTS := CY-SWR1100
   BLOCKSIZE := 64k
   KERNEL := $(KERNEL_DTB)
-  IMAGES += factory.bin
-  IMAGE/sysupgrade.bin := \
-       append-kernel | pad-offset $$$$(BLOCKSIZE) 64 | append-rootfs | \
-       seama -m "dev=/dev/mtdblock/2" -m "type=firmware" | \
-       pad-rootfs | append-metadata | check-size $$$$(IMAGE_SIZE)
-  IMAGE/factory.bin := \
-       append-kernel | pad-offset $$$$(BLOCKSIZE) 64 | \
-       append-rootfs | pad-rootfs -x 64 | \
-       seama -m "dev=/dev/mtdblock/2" -m "type=firmware" | \
-       seama-seal -m "signature=wrgnd10_samsung_ss815" | \
-       check-size $$$$(IMAGE_SIZE)
-  DEVICE_TITLE := Samsung CY-SWR1100
+  SEAMA_SIGNATURE := wrgnd10_samsung_ss815
+  DEVICE_VENDOR := Samsung
+  DEVICE_MODEL := CY-SWR1100
   DEVICE_PACKAGES := kmod-usb-core kmod-usb-ohci kmod-usb2 swconfig
 endef
 TARGET_DEVICES += cy-swr1100
 
 
 define Device/dir-645
+  $(Device/seama)
   DTS := DIR-645
   BLOCKSIZE := 4k
   KERNEL := $(KERNEL_DTB)
-  IMAGES += factory.bin
-  IMAGE/sysupgrade.bin := \
-       append-kernel | pad-offset $$$$(BLOCKSIZE) 64 | append-rootfs | \
-       seama -m "dev=/dev/mtdblock/2" -m "type=firmware" | \
-       pad-rootfs | append-metadata | check-size $$$$(IMAGE_SIZE)
-  IMAGE/factory.bin := \
-       append-kernel | pad-offset $$$$(BLOCKSIZE) 64 | \
-       append-rootfs | pad-rootfs -x 64 | \
-       seama -m "dev=/dev/mtdblock/2" -m "type=firmware" | \
-       seama-seal -m "signature=wrgn39_dlob.hans_dir645" | \
-       check-size $$$$(IMAGE_SIZE)
-  DEVICE_TITLE := D-Link DIR-645
+  SEAMA_SIGNATURE := wrgn39_dlob.hans_dir645
+  DEVICE_VENDOR := D-Link
+  DEVICE_MODEL := DIR-645
   DEVICE_PACKAGES := kmod-usb-core kmod-usb-ohci kmod-usb2 swconfig
 endef
 TARGET_DEVICES += dir-645
 
 
+define Device/belkin_f9k1109v1
+  DTS := F9K1109V1
+  BLOCKSIZE := 64k
+  DEVICE_VENDOR := Belkin
+  DEVICE_MODEL := F9K1109
+  DEVICE_VARIANT := Version 1.0
+  DEVICE_PACKAGES := kmod-usb-core kmod-usb-ohci kmod-usb2 swconfig
+  IMAGE_SIZE := 7224k
+  KERNEL := kernel-bin | patch-dtb | lzma -d16 | uImage lzma
+  # Stock firmware checks for this uImage image name during upload.
+  UIMAGE_NAME := N750F9K1103VB
+endef
+TARGET_DEVICES += belkin_f9k1109v1
+
 define Device/hpm
   DTS := HPM
   BLOCKSIZE := 64k
   IMAGE_SIZE := 16064k
-  DEVICE_TITLE := Omnima HPM
+  DEVICE_VENDOR := Omnima
+  DEVICE_MODEL := HPM
   DEVICE_PACKAGES := kmod-usb-core kmod-usb-ohci kmod-usb2
 endef
 TARGET_DEVICES += hpm
@@ -72,9 +72,9 @@ TARGET_DEVICES += hpm
 define Device/rt-n56u
   DTS := RT-N56U
   BLOCKSIZE := 64k
-  IMAGES += factory.bin
   IMAGE/sysupgrade.bin += | mkrtn56uimg -s
-  DEVICE_TITLE := Asus RT-N56U
+  DEVICE_VENDOR := Asus
+  DEVICE_MODEL := RT-N56U
   DEVICE_PACKAGES := kmod-usb-core kmod-usb-ohci kmod-usb2 swconfig
 endef
 TARGET_DEVICES += rt-n56u
@@ -86,7 +86,8 @@ define Device/tew-691gr
   IMAGES += factory.bin
   IMAGE/factory.bin := $$(sysupgrade_bin) | check-size $$$$(IMAGE_SIZE) | \
        umedia-header 0x026910
-  DEVICE_TITLE := TRENDnet TEW-691GR
+  DEVICE_VENDOR := TRENDnet
+  DEVICE_MODEL := TEW-691GR
   DEVICE_PACKAGES := swconfig
 endef
 TARGET_DEVICES += tew-691gr
@@ -98,7 +99,8 @@ define Device/tew-692gr
   IMAGES += factory.bin
   IMAGE/factory.bin := $$(sysupgrade_bin) | check-size $$$$(IMAGE_SIZE) | \
        umedia-header 0x026920
-  DEVICE_TITLE := TRENDnet TEW-692GR
+  DEVICE_VENDOR := TRENDnet
+  DEVICE_MODEL := TEW-692GR
   DEVICE_PACKAGES := swconfig
 endef
 TARGET_DEVICES += tew-692gr
@@ -111,7 +113,17 @@ define Device/wlr-6000
   IMAGES += factory.dlf
   IMAGE/factory.dlf := $$(sysupgrade_bin) | check-size $$$$(IMAGE_SIZE) | \
        senao-header -r 0x0202 -p 0x41 -t 2
-  DEVICE_TITLE := Sitecom WLR-6000
+  DEVICE_VENDOR := Sitecom
+  DEVICE_MODEL := WLR-6000
   DEVICE_PACKAGES := kmod-usb-core kmod-usb-ohci kmod-usb2 swconfig
 endef
 TARGET_DEVICES += wlr-6000
+
+
+define Device/wmdr-143n
+  DTS := WMDR-143N
+  BLOCKSIZE := 64k
+  DEVICE_VENDOR := Loewe
+  DEVICE_MODEL := WMDR-143N
+endef
+TARGET_DEVICES += wmdr-143n