kernel: update 3.14 to 3.14.18
[openwrt/staging/luka.git] / target / linux / ramips / patches-3.14 / 0037-USB-phy-add-ralink-SoC-driver.patch
index 38eae685630f00f004bca575e8eb9b472a198d56..9920afbac32d298fb33d3857d8465da030cf612a 100644 (file)
@@ -11,11 +11,9 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
  3 files changed, 199 insertions(+)
  create mode 100644 drivers/usb/phy/ralink-phy.c
 
-Index: linux-3.14.16/drivers/usb/phy/Kconfig
-===================================================================
---- linux-3.14.16.orig/drivers/usb/phy/Kconfig 2014-08-08 01:50:59.000000000 +0200
-+++ linux-3.14.16/drivers/usb/phy/Kconfig      2014-08-24 12:39:21.094371467 +0200
-@@ -251,6 +251,14 @@
+--- a/drivers/usb/phy/Kconfig
++++ b/drivers/usb/phy/Kconfig
+@@ -251,6 +251,14 @@ config USB_RCAR_GEN2_PHY
          To compile this driver as a module, choose M here: the
          module will be called phy-rcar-gen2-usb.
  
@@ -30,19 +28,15 @@ Index: linux-3.14.16/drivers/usb/phy/Kconfig
  config USB_ULPI
        bool "Generic ULPI Transceiver Driver"
        depends on ARM
-Index: linux-3.14.16/drivers/usb/phy/Makefile
-===================================================================
---- linux-3.14.16.orig/drivers/usb/phy/Makefile        2014-08-08 01:50:59.000000000 +0200
-+++ linux-3.14.16/drivers/usb/phy/Makefile     2014-08-24 12:39:21.094371467 +0200
-@@ -33,3 +33,4 @@
+--- a/drivers/usb/phy/Makefile
++++ b/drivers/usb/phy/Makefile
+@@ -33,3 +33,4 @@ obj-$(CONFIG_USB_RCAR_GEN2_PHY)              += phy-
  obj-$(CONFIG_USB_ULPI)                        += phy-ulpi.o
  obj-$(CONFIG_USB_ULPI_VIEWPORT)               += phy-ulpi-viewport.o
  obj-$(CONFIG_KEYSTONE_USB_PHY)                += phy-keystone.o
 +obj-$(CONFIG_RALINK_USBPHY)           += ralink-phy.o
-Index: linux-3.14.16/drivers/usb/phy/ralink-phy.c
-===================================================================
---- /dev/null  1970-01-01 00:00:00.000000000 +0000
-+++ linux-3.14.16/drivers/usb/phy/ralink-phy.c 2014-08-24 14:28:35.886531881 +0200
+--- /dev/null
++++ b/drivers/usb/phy/ralink-phy.c
 @@ -0,0 +1,191 @@
 +/*
 + * Copyright (C) 2013 John Crispin <blogic@openwrt.org>