ramips: refresh patches
[openwrt/staging/hauke.git] / target / linux / ramips / patches-5.4 / 0044-i2c-MIPS-adds-ralink-I2C-driver.patch
index 4905aba046c5856dfdb1a7586c62610fbc307135..e3bb7f24881ef8f1ddcd930f24352a33dc676c71 100644 (file)
@@ -45,7 +45,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
 +};
 --- a/drivers/i2c/busses/Kconfig
 +++ b/drivers/i2c/busses/Kconfig
-@@ -864,6 +864,11 @@ config I2C_RK3X
+@@ -922,6 +922,11 @@ config I2C_RK3X
          This driver can also be built as a module. If so, the module will
          be called i2c-rk3x.
  
@@ -59,14 +59,14 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
        help
 --- a/drivers/i2c/busses/Makefile
 +++ b/drivers/i2c/busses/Makefile
-@@ -84,6 +84,7 @@ obj-$(CONFIG_I2C_PNX)                += i2c-pnx.o
+@@ -91,6 +91,7 @@ obj-$(CONFIG_I2C_PNX)                += i2c-pnx.o
  obj-$(CONFIG_I2C_PUV3)                += i2c-puv3.o
  obj-$(CONFIG_I2C_PXA)         += i2c-pxa.o
  obj-$(CONFIG_I2C_PXA_PCI)     += i2c-pxa-pci.o
 +obj-$(CONFIG_I2C_RALINK)      += i2c-ralink.o
+ obj-$(CONFIG_I2C_QCOM_GENI)   += i2c-qcom-geni.o
  obj-$(CONFIG_I2C_QUP)         += i2c-qup.o
  obj-$(CONFIG_I2C_RIIC)                += i2c-riic.o
- obj-$(CONFIG_I2C_RK3X)                += i2c-rk3x.o
 --- /dev/null
 +++ b/drivers/i2c/busses/i2c-ralink.c
 @@ -0,0 +1,435 @@