Move to 2.6.22.4
[openwrt/svn-archive/archive.git] / target / linux / rb532-2.6 / Makefile
index 4daa728a5ad359aac455ce9986ae8613320b0fb6..ee2360187c9e393d48bf1053b9f0a6388974e75a 100644 (file)
@@ -6,16 +6,16 @@
 #
 include $(TOPDIR)/rules.mk
 
-LINUX_VERSION:=2.6.17
-LINUX_RELEASE:=1
-LINUX_KERNEL_MD5SUM:=37ddefe96625502161f075b9d907f21e
+ARCH:=mipsel
+BOARD:=rb532
+BOARDNAME:=Mikrotik RouterBoard 532
+FEATURES:=jffs2 pci tgz
+
+LINUX_VERSION:=2.6.22.4
 
-include ./config
 include $(INCLUDE_DIR)/kernel-build.mk
 
-$(LINUX_DIR)/.patched: $(LINUX_DIR)/.unpacked
-       [ -d ../generic-$(KERNEL)/patches ] && $(PATCH) $(LINUX_DIR) ../generic-$(KERNEL)/patches
-       [ -d ./patches ] && $(PATCH) $(LINUX_DIR) ./patches
-       @$(CP) config $(LINUX_DIR)/.config
-       touch $@
+# include the profiles
+-include profiles/*.mk
 
+$(eval $(call BuildKernel))